Squad: Alpha 3.8

Posted: 24/12/2015 in News - Archive, Squad
Tags: , , , ,

Squad logo

Large number of bug fixes in this hotfix, including an attempt to fix the disconnect issue, fixes to Ping on the server browser, and more. Also in this hotfix we are pushing live a new set of Texture Streaming settings, which fixes a possible hitch when turning rapidly, and helps increase performance overall. If you’ve been having low FPS, let us know how this patch works for you.

Alpha 3.8

  • Fixed a bug where the FOV could be set outside the range
  • Further pass on optimizing the animation system
  • Fixed an incorrect name on Sumari
  • Fixed a possible performance issue in the Animation System on AMD processors
  • Fixed a server crash when creating a squad
  • Fixed an issue where aim offsets would be wrong when aiming down
  • Fixed an issue where the recurit kit was not being given to people who leave the squad
  • Fixed an issue where the gamemode rules weren’t being shown on map switch
  • Disabled Framerate smoothing by default (was causing FPS lock on certain machines)
  • Further pass on the map legend to ensure that all gamemodes were covered
  • Fixed a bug where Rally Point Error Messages were being sent to the wrong player
  • Added new sounds for Prone Movement and Sprinting
  • Fixed Ammo Crates posting a message on the HUD when used
  • Added ‘Streamer Mode’ to the game options. This disables the Server Name on the scoreboard and a few other things
  • Fixed destroying friendly FOBs would deduct your team’s tickets
  • Adjusted the attenuation settings on rocket flybys
  • Added placement sounds for Rally Points
  • Fixed Fools Road not being properly randomized when selecting a random variation
  • Fixed an issue where the server would look up UserSettings for every player joining the server
  • Enabled texture streaming and increased the texture streaming settings
  • Updated the Lod Bias on every asset, vastly improving Video Memory usage and rendering speed
  • Fixed a bug where the ‘End Use’ message would not be sent when a player died while using an object. Fixes the Ammo crate menu sticking around when you died while using it.
  • Fixed a visual ‘jumping’ when a player is revived and goes into prone
  • Upped the spawn delay on FOBs from 5s per enemy to 10s per enemy in the radius
  • Added better logging when players are disconnected from servers to help debug the disconnection issues
  • Changed ‘Training’ to ‘Firing Range’ on the main menu
  • Fixed a server crash when validating player inventories
  • Added Ping to the server browser
  • Fixed a display issue with scoreboard pings (they were too high)
  • Fixed a possible cause of the disconnect bug, where players were attempting to switch to an empty weapon
  • Changed the handling of the Server Name, so it’ll update more often
  • Removed some extra ammo crates in Fools Road
  • Improved the handling of getting stuck in objects

LINK

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s